Back to overview
Degraded

Support Platform Outage

Apr 17 at 05:30am CDT
Affected services
Support System

Resolved
Apr 17 at 07:33am CDT

We are pleased to report that the earlier outage affecting our Support Platform has been resolved. Our engineering team successfully identified and addressed the issue, restoring full functionality to the platform.

Created
Apr 17 at 05:30am CDT

We are currently experiencing an outage affecting our Support Platform. Our engineering team is aware of the issue and is actively investigating to determine the cause and restore service.

Emergency procedures are in place and functioning correctly. This ensures that our support levels remain unaffected. Our team continues to handle all urgent support queries through alternative protocols.